Mikrotik CRS125-24G-1S-RM with OpenStack Neutron

A quick follow up from my preview post on Getting Started with Multi-Node OpenStack RDO Havana + Gluster Backend + Neutron VLAN

In my lab environment I had access to the switch (24 port gigabit switch from Mikrotik http://routerboard.com/CRS125-24G-1S-RM)

Great hardware and got it for an amazing price from our local distrubutor here in Australia. Mike @ Duxtel was very helpful http://shop.duxtel.com.au/productinfo.php?cPath=30&productsid=290

Generally this can be where the most annoying network issues can occur when you setup VLANs and OpenStack networking. If you've got the same switch as me here were the quick VLAN configs I did.

Unfortunately because it being such a new device, not all the components are in the GUI. If you're used to Cisco's horrible GUI then think again because Mikrotik did an amazing job and it's close to as fast as the command line.

What I did was seperate the three switches (within the device) into three components:

Ether 1(master port) - 8 = Gateway, Public (192.168.0.0/24), DRAC/RSA Management Ports

Ether 9-16 = Management (172.16.0.0/24)

Ether 17(master port)-24 = VM Data

/interface vlan
add comment="OpenStack Tenant VLANs" interface=ether17-master l2mtu=1584 name=vlan10 vlan-id=10  
add interface=ether17-master l2mtu=1584 name=vlan11 vlan-id=11  
add interface=ether17-master l2mtu=1584 name=vlan12 vlan-id=12  
add interface=ether17-master l2mtu=1584 name=vlan13 vlan-id=13  
add interface=ether17-master l2mtu=1584 name=vlan14 vlan-id=14  
add interface=ether17-master l2mtu=1584 name=vlan15 vlan-id=15  
add interface=ether17-master l2mtu=1584 name=vlan16 vlan-id=16  
add interface=ether17-master l2mtu=1584 name=vlan17 vlan-id=17  
add interface=ether17-master l2mtu=1584 name=vlan18 vlan-id=18  
add interface=ether17-master l2mtu=1584 name=vlan19 vlan-id=19  
add interface=ether17-master l2mtu=1584 name=vlan20 vlan-id=20

/interface ethernet set ether17 master-port=none
/interface ethernet set ether17 name=ether17-master
/interface ethernet set ether18 master-port=none
/interface ethernet set ether18 master-port=ether17
/interface ethernet set ether19 master-port=none
/interface ethernet set ether19 master-port=ether17 
/interface ethernet set ether20 master-port=none
/interface ethernet set ether20 master-port=none
/interface ethernet set ether21 master-port=ether17
/interface ethernet set ether21 master-port=ether17
/interface ethernet set ether22 master-port=none
/interface ethernet set ether22 master-port=ether17
/interface ethernet set ether23 master-port=none
/interface ethernet set ether23 master-port=ether17
/interface ethernet set ether24 master-port=none
/interface ethernet set ether24 master-port=ether17

/ip address add address=192.168.0.1/24 comment="Public Network" interface=ether02-master network=192.168.0.0
/ip address add address=172.16.0.1/24 comment="Management Network" interface=ether02-master network=172.16.0.0

When you understand the concept of master ports in the Mikrotik switch environment it becomes super fast and easy to setup!

So far I'm loving the full wire speeds on all 24 gigabit ports from a $200 device. How can you complain?

Hope this helps!

comments powered by Disqus